Skip to main content

Netskope Help

Migrating from CE 3.1 or newer to CE 3.4.0

To preserve existing data (indicators, plugin configurations) while migrating from any version of CE 3.x to a higher version, follow the steps below. If you are upgrading Cloud Exchange from a version older than 3.1, please upgrade to 3.4.0 using these instructions: Migrating from CE 2.x to CE 3.x .

Important

Before you begin, grab the MONGO_DB password from the old setup. This is required during the installation of the new setup (as the value for Maintenance Password). If the Mongo password is lost, the data will not be retained.

The MongoDB password can be found in docker-compose.yml file (value of MONGODB_PASSWORD), or in the .env file (value of MONGODB_PASSWORD). Both of these files are in the /ta_cloud_exchange directory. Use this as the value for the Maintenance Password while running the setup in step 5.

  1. Navigate to the existing ta_cloud_exchange directory with the docker-compose.yml file.

  2. Stop the Cloud Exchange containers.

    $ ./stop

    If the output of ./stop command is ./stop: No such file or directory, execute the following command:

    $ docker-compose stop
  3. If you have made any local changes to the docker-compose.yml file, reset those using:

    $ git reset --hard
  4. Pull the latest changes:

    $ git pull
  5. Execute the setup script (do not use sudo).

    $ python3 ./setup
  6. Launch Cloud Exchange (do not use sudo).

    $ ./start

Note

Check the configured plugins after migration. You may need to reconfigure some plugins due to new plugin changes.

The Cloud Exchange UI is now accessible with the system’s IP. (e.g. https://<ip>).