Docy

Apps Supported in Classic and Next Generation API Data Protection

Apps Supported in Classic and Next Generation API Data Protection

The following table lists the various apps supported in the legacy a.k.a Classic & Next Generation API Data Protection:

App NameClassic API Data ProtectionNext Generation API Data Protection

Atlassian Confluence

-

Atlassian Jira

-

Box

-

Cisco Webex Teams

-

Citrix ShareFile

-

Dropbox

-

Egnyte

-

GitHub

*

See special instruction at the bottom.

Gmail

-

*

See special instruction at the bottom.

Google Drive

*

See special instruction at the bottom.

Microsoft 365 OneDrive GCC High

-

Microsoft 365 SharePoint GCC High

-

Microsoft 365 Teams GCC High

-

Microsoft 365 Yammer

-

Microsoft OneDrive (Commercial)

*

See special instruction at the bottom.

Microsoft Outlook (Commercial)

*

See special instruction at the bottom.

Microsoft SharePoint (Commercial)

*

See special instruction at the bottom.

Microsoft Teams

-

Okta

-

Salesforce

-

ServiceNow

-

Slack Enterprise

-

Slack Team

-

Workday

-

Workplace from Meta

-

Zendesk

-

Zoom

-

GitHub

* GitHub app is now available on the Next Generation API Data Protection platform. Please note the following important points:

  • The classic version of the GitHub app is now deprecated. New customers can no longer set up a new GitHub app instance on the classic platform. If you need to setup a new instance of GitHub, select the GitHub app available under Next Generation platform.

  • If you currently use the classic version of the GitHub app, no action required. You should continue to use the classic version that you use today. Netskope will notify you via a banner message on the Netskope tenant UI when you can switch over to the Next Generation app.

Gmail

* Gmail app is now available on the Next Generation API Data Protection platform. Please note the following important points:

  • If you are currently using the classic version of the Gmail app, the app will be migrated to the Next Generation platform. The migration process has already kick started as part of release 109. This transition will occur seamlessly, and we anticipate its completion within the coming weeks. Once migrated, you will no longer see the Gmail app under
    Configure App Access > Classic > SaaS. However,

    • the Gmail app will be available under Configure App Access > Next Gen > CASB API.

    • classic policies will be automatically migrated to Next Generation API Data Protection and will be available under Policies > API Data Protection > SAAS > Next Gen.

    • the Gmail dashboard page will be available under API-enabled Protection > SAAS (Next Gen) > Dashboard.

    • In addition, you can view the Inventory page under API-enabled Protection > SAAS (Next Gen) > Inventory.

  • If you currently do not use the classic version of the Gmail app, you can configure the Gmail app under Configure App Access > Next Gen > CASB API.

Google Drive

* Google Drive app is now available on the Next Generation API Data Protection platform. Please note the following important points:

  • If you currently use the classic version of the Google Drive app, no action required. You should continue to use the classic version that you use today. Netskope will notify you via a banner message on the Netskope tenant UI when you can switch over to the Next Generation apps.

  • If you currently do not use the classic version of the Google Drive app, Netskope will make the app available to you in phases. To check if the app is available on your Netskope tenant, follow the instruction below:

    1. Log in to your Netskope tenant and navigate to Settings > Configure App Access > Next Gen > CASB API.

    2. If you see the Google Drive app listed, you are eligible to configure the app on the Next Generation API Data Protection platform.

Microsoft 365 OneDrive & SharePoint (Commercial)

* Microsoft 365 OneDrive (commercial) and SharePoint (commercial) apps are now available on the Next Generation API Data Protection platform. Please note the following important points:

  • If you currently use the classic version of Microsoft 365 OneDrive and SharePoint apps, no action required. You should continue to use the classic version that you use today. Netskope will notify you via a banner message on the Netskope tenant UI when you can switch over to the Next Generation apps.

  • If you currently do not use the classic version of Microsoft 365 OneDrive and SharePoint apps, Netskope will make these apps available to you in phases. To check if these apps are available on your Netskope tenant, follow the instruction below:

    1. Log in to your Netskope tenant and navigate to Settings > Configure App Access > Next Gen > CASB API.

    2. Locate the OneDrive or SharePoint apps from the list.

    3. For OneDrive & SharePoint, click either of the apps, then click the SETUP <app name> INSTANCE button. Under the Office 365 Environment drop-down, if you see Commercial, you are eligible to configure the app on the Next Generation API Data Protection platform.

    4. If you do not see the apps, stay tuned, the apps will be made available in due course. In the meanwhile, you can continue to set up these apps available under Settings > Configure App Access > Classic > SaaS.

Microsoft 365 Outlook (Commercial)

Microsoft 365 Outlook app is now available on the Next Generation API Data Protection platform. Please note the following important points:

  • If you currently use the classic version of the Microsoft 365 Outlook app, no action required. You should continue to use the classic version that you use today. Netskope will notify you via a banner message on the Netskope tenant UI when you can switch over to the Next Generation apps.

  • If you currently do not use the classic version of the Microsoft 365 Outlook app, Netskope will make the app available to you in phases. To check if the app is available on your Netskope tenant, follow the instruction below:

    1. Log in to your Netskope tenant and navigate to Settings > Configure App Access > Next Gen > CASB API.

    2. If you see the Microsoft 365 Outlook app listed, you are eligible to configure the app on the Next Generation API Data Protection platform.

    3. If you do not see the app, stay tuned, the app will be made available in due course. In the meanwhile, you can continue to set up the app available under Settings > Configure App Access > Classic > SaaS.

Documentation Links

Share this Doc
In this topic ...