Skip to main content

Netskope Help

RBI Supported Browsers

Netskope RBI supports all modern browser releases of any major desktop browsers (e.g. Chrome, Edge, Firefox, IE, Safari, etc.) and mobile browsers (e.g. Chrome, Safari, etc.).

Some old browsers may not comply with the minimum set of requirements for RBI to work properly. In such circumstances, the end user is presented with a 'browser not supported' error message. The end user must use a different version to proceed with isolation.

RBI_Browser_warning_message.jpg